Domowe laboratorium – część 1 z … – Sieć cz.1

W poprzednim wpisie nakreśliłem nieco oczekiwania względem mojego laboratorium. Wymieniłem też jego główne elementy takie jak router, switch czy w końcu stacje robocze zwane serwerami.
W tym wpisie skupię się na konfiguracji sieci jaką stworzyłem na potrzeby mojej Chmury Prywatnej.

Zarys ogólny

Poniższy obrazek przedstawia w uproszczeniu sieć jaką posiadam w danej chwili:

Uproszczony schemat sieci

Założenie było takie, aby oddzielić ruch mojej sieci domowej od ruchu generowanego przez serwery w laboratorium.

Zacznijmy – konfiguracja MikroTik’a

W modelu 951G-2HnD mamy do dyspozycji 5 portów Ethernet o prędkości 1 Gbit każdy, oraz kartę WLAN (WiFi) pracującą w standardzie 802.11b/g/n.
W/w model posiada wbudowane dwie anteny 2×2 MIMO o mocy do 2,5 dBi każda. W przeciwieństwie do jego poprzednika, modelu 751G 2HnD, nie mamy tu wyprowadzenia na anteny w standardzie MMCX.

Jak widać na rysunku, wykorzystywane są dwa porty fizyczne routera oraz jego sieć WiFi.
W praktyce do portów 3 oraz 4 są podpięte odpowiednio: amplituner i telewizor, ale one nas w tym momencie nie interesują.

MikroTik, który do mnie przyjechał, jest skonfigurowany tak, że podczas pierwszego włączenia, a także po każdym “twardym” resecie, wgrywa predefiniowane ustawienia.
Ustawienia te ułatwiają szybsze rozpoczęcie pracy, jednak aby konfiguracja spełniała nasze potrzeby, musimy ją zmodyfikować.
Tak też było i w moim przypadku, dlatego poniżej zamieszczam moją konfigurację.

Zarządzanie MT

Do zarządzania routerem MikroTik mamy dostępnych kilka narzędzi.
Możemy wykorzystać do tego znanego większości telneta, dostępny jest również interfejs WWW.
Niemniej jednak, najwygodniej chyba zarządzać z poziomu dedykowanej aplikacji jaką jest WinBox, który możemy pobrać ze strony producenta LINK


Okno logowania do MikroTik’a

Jak widać na powyższym zdjęciu, za pomocą WinBox’a możemy podłączyć się do urządzenia, wskazując jego adres IP lub adres MAC interfejsu.
W przykładzie powyżej loguję się za pomocą adresu MAC. Jest to wygodne rozwiązanie w momencie, gdy operujemy na adresach IP interfejsów – przy ich zmianie nie zostaniemy przypadkowo odcięci!

Konfiguracja interfejsów i adresów IP

Aby zacząć przygodę z naszym laboratorium musimy skonfigurować w routerze interfejsy sieciowe oraz przypisać im adresy IP. Po zalogowaniu do urządzenia z poziomu WinBox’a uruchamiamy New Terminal

#Nadajemy nazwy naszym interfejsom

/interface ethernet set 0 name=WAN
/interface ethernet set 1 name=eth2
/interface ethernet set 2 name=eth3
/interface ethernet set 3 name=eth4
/interface ethernet set 4 name=eth5
/interface wireless set 0 name=wlan1

#Tworzymy wirtualny mostek w ramach którego znajdą się porty mojej domowej sieci LAN oraz sieć WiFi

/interface bridge add auto-mac=no l2mtu=1594 name=bridge-local protocol-mode=rstp

#Włączamy sieć WiFi

/interface wireless set 0 band=2ghz-b/g/n channel-width=20/40mhz-ht-above disabled=no distance=indoors ht-rxchains=0,1 ht-txchains=0,1 l2mtu=2290 mode=ap-bridge ssid=siec_wifi wireless-protocol=any

/interface wireless security-profiles set default authentication-types=wpa-psk,wpa2-psk eap-methods=passthrough mode=dynamic-keys supplicant-identity=MikroTik wpa-pre-shared-key=”moje_tajne_hasło” wpa2-pre-shared-key=”moje_tajne_hasło”

Gdy nadaliśmy już nazwy naszym portom, oraz skonfigurowaliśmy sieć WiFi oraz mostek, należy skonfigurować adresację IP.

#Tworzymy pulę adresów dla serwera DHCP

/ip pool add name=default-dhcp ranges=192.168.2.101-192.168.2.130

#Konfigurujemy serwer DHCP

/ip dhcp-server add address-pool=default-dhcp disabled=no interface=bridge-local name=default

#Dodajemy interfejsy MikroTika do mostka

/interface bridge port add bridge=bridge-local interface=wlan1
/interface bridge port add bridge=bridge-local interface=eth3
/interface bridge port add bridge=bridge-local interface=eth4

Jak można zauważyć, do mostka nie dodaliśmy portu eth2. Analizując rysunek pierwszy, widzimy, że na porcie eth2 odbywa się ruch w VLANach.
Aby obsłużyć taki ruch, należy dodać w tym momencie odpowiednie VLANy do naszej konfiguracji.

#Dodajemy VLANy

/interface vlan add interface=eth2 l2mtu=1594 name=”VLAN 10″ vlan-id=10
/interface vlan add interface=eth2 l2mtu=1594 name=”VLAN 20″ vlan-id=20

#Przypisujemy “VLAN 10” do mostka, aby umożliwić komunikację sieci lokalnej między siecią WiFi i komputerami wpiętymi w MikroTika do portu eth2, eth3 i eth4

/interface bridge port add bridge=bridge-local interface=”VLAN 10″

W chwili obecnej mamy skonfigurowane już poszczególne interfejsy i serwer DHCP, przyszedł czas aby tchnąć weń “ruch”
Nadajemy odpowiednią adresację

#Przydzielamy adres IP naszemu mostkowi

/ip address add address=192.168.2.1/24 comment=”” interface=bridge-local

#oraz VLANowi 20

/ip address  add address=10.0.2.1/24 interface=”VLAN 20″

#Uruchamiamy klienta DHCP na porcie WAN, tak aby MikroTik mógł uzyskać adres od naszego ISP

/ip dhcp-client add comment=”” disabled=no interface=WAN

#Dodajemy jeszcze konfigurację serwera DHCP

/ip dhcp-server network add address=192.168.2.0/24 comment=”” dns-server=192.168.2.1 gateway=192.168.2.1

Na koniec możemy jeszcze skonfigurować zegar naszego routera

/system clock set time-zone-name=Europe/Warsaw
/system identity set name=Router
/system ntp client set enabled=yes mode=unicast primary-ntp=212.244.36.227 secondary-ntp=212.244.36.228

Powyższa konfiguracja jest poprawna, ale brakuje w niej 1 linijki, dzięki której ruch z naszej sieci LAN oraz LAB będzie mógł “wyjść na świat”.
Mowa tu oczywiście o regule w firewall’u, a dokładnie o Source NAT, która odpowiada za translację adresów wewnętrznych na adres publiczny.

#Dodajemy regułę SNAT

/ip firewall nat add action=masquerade chain=srcnat out-interface=WAN

Na koniec, dodam jeszcze jedną przydatną linijkę kodu.

#Wykonujemy backup całej konfiguracji!

/system backup save name=nazwa_pliku

Jeśli popsujemy coś w naszej konfiguracji, w łatwy sposób będziemy mogli przywrócić naszą poprzednio zapisaną konfigurację

/system backup load name=nazwa_pliku

Pliki backupu zostają zapisane na dysku routera i pozostają na nim nawet w przypadku wykonania twardego resetu urządzenia.

Podsumowanie

Powyżej zamieściłem opis sieci od strony routera MikroTik i jego podstawową konfigurację.
Przy takiej konfiguracji, komputery wpięte do portów eth3 i eth4 oraz poprzez sieć WiFi będą już mogły korzystać z Internetu i sieci lokalnej.
Aby obsłużyć ruch na porcie eth2 będzie konieczna konfiguracja przełącznika który widoczny jest na obrazku pierwszym pod nazwą NETGEAR.
Opis jego konfiguracji znajdziesz w kolejnym wpisie.

It's only fair to share...Share on Facebook0Share on Google+0Tweet about this on TwitterShare on LinkedIn0
  • Pingback: Domowe laboratorium – część 2 z … – Sieć cz. 2 « Inne « Emil Wasilewski()

  • Jacek

    Witaj,

    Mam mikrotika rb435G, który funkcjonuje jako Hotspot na:
    ether1 – podłączenie do adsl i internet
    ether2 – wyjście do zewnętrznego switcha
    ether3 – wyłączony
    wlan – włączony

    po czym zrobiłem most (bridge) z hotspotem i dałem sygnał z ether1 na ether2 i wlan gdzie podłączona jest antena i daje sygnał jako AP1

    ether 2 ma podłączenie do switcha gdzie mają zostać podłączone AP-eki LOCO M2

    mój problem polega na tym, że po podłaczeniu Apeków LOCO M2 do switcha nie mozan podłączyć się z HOTSPOTEM – Telefon czy Laptop wyszukuje widzi APeka ale nie może się podłączyć , wyszukuje tylko IP

    a jak podłącze bezpośrednio APeka M2 do Ether2 (bez switcha) to wszystko śmiga

    najgorsze jest to że muszę podłączyć do switcha 4 APeki gdzie ma zostać rozprowadzony sygnał po budynkach.

    prawdopodobnie coś źle konfiguruje wyjście ether2

    znajomy mi powiedział że muszę dodać adresy MAC z każdego APeka – ale nie wiem gdzie

    czy możesz mi pomóc

    Pozdrawiam
    Jacek